re = /\[(.+)?\] (.+?) (S\d* )?- (\d+) \[(.+)\]/i
str = '[HorribleSubs] Fate Kaleid Liner PRISMA ILYA - 01 [720p]
[HorribleSubs] Akame ga Kill! - 02 [720p].mkv
[HorribleSubs] Aldnoah Zero - 08 [720p]
[HorribleSubs] Deadman Wonderland - 02 [720p]
[HorribleSubs] Tokyo Ghoul Root A - 01 [720p]
[HorribleSubs] Sword Art Online II - 02 [1080p]
[HorribleSubs] Yahari Ore no Seishun Love Come wa Machigatteiru Zoku - 07 [720p].mkv
[HorribleSubs] Love Live! S2 - 02 [720p]
[HorribleSubs] Fairy Tail S2 - 02 [720p].mkv'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end