#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\:\w+\:|\<[\/\\]?3|[\(\)\\\D|\*\$][\-\^]?[\:\;\=]|[\:\;\=B8][\-\^]?[3DOPp\@\$\*\\\)\(\/\|])(?=\s|[\!\.\?]|$)"
Local $sString = ":( Hello!" & @CRLF & _
"Howdy :)!" & @CRLF & _
"Are you there :P?" & @CRLF & _
"I'm fine :)" & @CRLF & _
":p" & @CRLF & _
":O" & @CRLF & _
":3" & @CRLF & _
":|" & @CRLF & _
":/" & @CRLF & _
":\" & @CRLF & _
":$" & @CRLF & _
":*" & @CRLF & _
":@" & @CRLF & _
"" & @CRLF & _
":-(" & @CRLF & _
":-)" & @CRLF & _
":-P" & @CRLF & _
":-p" & @CRLF & _
":-O" & @CRLF & _
":-3" & @CRLF & _
":-|" & @CRLF & _
":-/" & @CRLF & _
":-\" & @CRLF & _
":-$" & @CRLF & _
":-*" & @CRLF & _
":-@" & @CRLF & _
"" & @CRLF & _
":^(" & @CRLF & _
":^)" & @CRLF & _
":^P" & @CRLF & _
":^p" & @CRLF & _
":^O" & @CRLF & _
":^3" & @CRLF & _
":^|" & @CRLF & _
":^/" & @CRLF & _
":^\" & @CRLF & _
":^$" & @CRLF & _
":^*" & @CRLF & _
":^@" & @CRLF & _
"" & @CRLF & _
"):" & @CRLF & _
"(:" & @CRLF & _
"$:" & @CRLF & _
"*:" & @CRLF & _
"" & @CRLF & _
")-:" & @CRLF & _
"(-:" & @CRLF & _
"$-:" & @CRLF & _
"*-:" & @CRLF & _
"" & @CRLF & _
")^:" & @CRLF & _
"(^:" & @CRLF & _
"$^:" & @CRLF & _
"*^:" & @CRLF & _
"" & @CRLF & _
"<3" & @CRLF & _
"</3" & @CRLF & _
"<\3" & @CRLF & _
"" & @CRLF & _
":smile:" & @CRLF & _
":hug:" & @CRLF & _
":pencil:" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")