using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\:\w+\:|\<[\/\\]?3|[\(\)\\\D|\*\$][\-\^]?[\:\;\=]|[\:\;\=B8][\-\^]?[3DOPp\@\$\*\\\)\(\/\|])(?=\s|[\!\.\?]|$)";
string input = @":( Hello!
Howdy :)!
Are you there :P?
I'm fine :)
:p
:O
:3
:|
:/
:\
:$
:*
:@
:-(
:-)
:-P
:-p
:-O
:-3
:-|
:-/
:-\
:-$
:-*
:-@
:^(
:^)
:^P
:^p
:^O
:^3
:^|
:^/
:^\
:^$
:^*
:^@
):
(:
$:
*:
)-:
(-:
$-:
*-:
)^:
(^:
$^:
*^:
<3
</3
<\3
:smile:
:hug:
:pencil:
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}