use strict;
my $str = ':( Hello!
Howdy :)!
Are you there :P?
I\'m fine :)
:p
:O
:3
:|
:/
:\\
:$
:*
:@
:-(
:-)
:-P
:-p
:-O
:-3
:-|
:-/
:-\\
:-$
:-*
:-@
:^(
:^)
:^P
:^p
:^O
:^3
:^|
:^/
:^\\
:^$
:^*
:^@
):
(:
$:
*:
)-:
(-:
$-:
*-:
)^:
(^:
$^:
*^:
<3
</3
<\\3
:smile:
:hug:
:pencil:
';
my $regex = qr/(\:\w+\:|\<[\/\\]?3|[\(\)\\\D|\*\$][\-\^]?[\:\;\=]|[\:\;\=B8][\-\^]?[3DOPp\@\$\*\\\)\(\/\|])(?=\s|[\!\.\?]|$)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}