$re = '/(\:\w+\:|\<[\/\\\\]?3|[\(\)\\\\\D|\*\$][\-\^]?[\:\;\=]|[\:\;\=B8][\-\^]?[3DOPp\@\$\*\\\\\)\(\/\|])(?=\s|[\!\.\?]|$)/';
$str = ':( Hello!
Howdy :)!
Are you there :P?
I\'m fine :)
:p
:O
:3
:|
:/
:\\
:$
:*
:@
:-(
:-)
:-P
:-p
:-O
:-3
:-|
:-/
:-\\
:-$
:-*
:-@
:^(
:^)
:^P
:^p
:^O
:^3
:^|
:^/
:^\\
:^$
:^*
:^@
):
(:
$:
*:
)-:
(-:
$-:
*-:
)^:
(^:
$^:
*^:
<3
</3
<\\3
:smile:
:hug:
:pencil:
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);