package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:\s*#.*\n)*(\w+)\s*=\s*((?:[^#=\n]+(?:\n|$))+)`)
var str = `tag = value
tag2 = value2
value continuation2
# comment for tag3
tag3 = value3`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}