$re = '/(?:\s*#.*\n)*(\w+)\s*=\s*((?:[^#=\n]+(?:\n|$))+)/';
$str = 'tag = value
tag2 = value2
value continuation2
# comment for tag3
tag3 = value3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);