import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\s*#.*\\n)*(\\w+)\\s*=\\s*((?:[^#=\\n]+(?:\\n|$))+)";
final String string = "tag = value\n"
+ "tag2 = value2\n"
+ "value continuation2\n"
+ "# comment for tag3\n"
+ "tag3 = value3";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}