using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"to(?: \w+)? CITY\d";
string input = @"John from beautiful CITY1 in sdfsf to dsfs in sf to abc CITY2 to CITY3 for 3 days";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}