const regex = /to(?: \w+)? CITY\d/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('to(?: \\w+)? CITY\\d', 'g')
const str = `John from beautiful CITY1 in sdfsf to dsfs in sf to abc CITY2 to CITY3 for 3 days`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}