re = /to(?: \w+)? CITY\d/
str = 'John from beautiful CITY1 in sdfsf to dsfs in sf to abc CITY2 to CITY3 for 3 days'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end