// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"to(?: \w+)? CITY\d").unwrap();
let string = "John from beautiful CITY1 in sdfsf to dsfs in sf to abc CITY2 to CITY3 for 3 days";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}