package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`to(?: \w+)? CITY\d`)
var str = `John from beautiful CITY1 in sdfsf to dsfs in sf to abc CITY2 to CITY3 for 3 days`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}