package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:ht|f)tps?:\/\/[-a-zA-Z0-9.]+\.[a-zA-Z]{2,3}(?:\/(?:[^"<=]|=)*)?`)
var str = `href="http://vacante2016.eu/tr/17599/51743713/c4f5eadf38eb475d39e3cde=ca9201538"
"http://vacante2016.eu/clk/17599/5=\r\n1743713/150132/bf7639dd7e7aa48c9197a52a8c61e168"><img`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}