use strict;
my $str = 'href="http://vacante2016.eu/tr/17599/51743713/c4f5eadf38eb475d39e3cde=ca9201538"
"http://vacante2016.eu/clk/17599/5=\\r\\n1743713/150132/bf7639dd7e7aa48c9197a52a8c61e168"><img';
my $regex = qr/(?:ht|f)tps?:\/\/[-a-zA-Z0-9.]+\.[a-zA-Z]{2,3}(?:\/(?:[^"<=]|=)*)?/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}