import re
regex = re.compile(r"(?:ht|f)tps?:\/\/[-a-zA-Z0-9.]+\.[a-zA-Z]{2,3}(?:\/(?:[^\"<=]|=)*)?")
test_str = ("href=\"http://vacante2016.eu/tr/17599/51743713/c4f5eadf38eb475d39e3cde=ca9201538\" \n"
"\"http://vacante2016.eu/clk/17599/5=\\r\\n1743713/150132/bf7639dd7e7aa48c9197a52a8c61e168\"><img")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")