// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?:ht|f)tps?:\/\/[-a-zA-Z0-9.]+\.[a-zA-Z]{2,3}(?:\/(?:[^"<=]|=)*)?"#).unwrap();
let string = "href=\"http://vacante2016.eu/tr/17599/51743713/c4f5eadf38eb475d39e3cde=ca9201538\"
\"http://vacante2016.eu/clk/17599/5=\\r\\n1743713/150132/bf7639dd7e7aa48c9197a52a8c61e168\"><img";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}