const regex = /(?:ht|f)tps?:\/\/[-a-zA-Z0-9.]+\.[a-zA-Z]{2,3}(?:\/(?:[^"<=]|=)*)?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:ht|f)tps?:\\\/\\\/[-a-zA-Z0-9.]+\\.[a-zA-Z]{2,3}(?:\\\/(?:[^"<=]|=)*)?', 'g')
const str = `href="http://vacante2016.eu/tr/17599/51743713/c4f5eadf38eb475d39e3cde=ca9201538"
"http://vacante2016.eu/clk/17599/5=\\r\\n1743713/150132/bf7639dd7e7aa48c9197a52a8c61e168"><img`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}