#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)(?<=;)(?!(?:(?!BEGIN).)*END)"
Local $sString = "ALTER TABLE _version ADD test1 INT NOT NULL;" & @CRLF & _
"ALTER TABLE _version ADD test2 INT NOT NULL;" & @CRLF & _
"CREATE PROCEDURE test3 ()" & @CRLF & _
" LANGUAGE SQL" & @CRLF & _
" DETERMINISTIC" & @CRLF & _
" SQL SECURITY DEFINER" & @CRLF & _
" COMMENT 'A procedure'" & @CRLF & _
" BEGIN" & @CRLF & _
" SELECT 'Hello World !';" & @CRLF & _
" END;"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")