# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=;)(?!(?:(?!BEGIN).)*END)"
test_str = ("ALTER TABLE _version ADD test1 INT NOT NULL;\n"
"ALTER TABLE _version ADD test2 INT NOT NULL;\n"
"CREATE PROCEDURE test3 ()\n"
" LANGUAGE SQL\n"
" DETERMINISTIC\n"
" SQL SECURITY DEFINER\n"
" COMMENT 'A procedure'\n"
" BEGIN\n"
" SELECT 'Hello World !';\n"
" END;")
matches = re.finditer(regex, test_str, re.DOTALL)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.