re = /(?<=;)(?!(?:(?!BEGIN).)*END)/
str = 'ALTER TABLE _version ADD test1 INT NOT NULL;
ALTER TABLE _version ADD test2 INT NOT NULL;
CREATE PROCEDURE test3 ()
LANGUAGE SQL
DETERMINISTIC
SQL SECURITY DEFINER
COMMENT \'A procedure\'
BEGIN
SELECT \'Hello World !\';
END;'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end