$re = '/(?<=;)(?!(?:(?!BEGIN).)*END)/s';
$str = 'ALTER TABLE _version ADD test1 INT NOT NULL;
ALTER TABLE _version ADD test2 INT NOT NULL;
CREATE PROCEDURE test3 ()
LANGUAGE SQL
DETERMINISTIC
SQL SECURITY DEFINER
COMMENT \'A procedure\'
BEGIN
SELECT \'Hello World !\';
END;';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);