import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=;)(?!(?:(?!BEGIN).)*END)";
final String string = "ALTER TABLE _version ADD test1 INT NOT NULL;\n"
+ "ALTER TABLE _version ADD test2 INT NOT NULL;\n"
+ "CREATE PROCEDURE test3 ()\n"
+ " LANGUAGE SQL\n"
+ " DETERMINISTIC\n"
+ " SQL SECURITY DEFINER\n"
+ " COMMENT 'A procedure'\n"
+ " BEGIN\n"
+ " SELECT 'Hello World !';\n"
+ " END;";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}