#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)\B#+([a-z]\w*(?!#)\b)"
Local $sString = "Hello #world" & @CRLF & _
"#lol #sorryNotSorry #heya #coolbeans" & @CRLF & _
"# # # #" & @CRLF & _
"this is an in#line hash" & @CRLF & _
"too ##many tags" & @CRLF & _
"invalid chars #$? #;wha" & @CRLF & _
"" & @CRLF & _
"#blue#red#yellow#green"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")