const regex = /\B#+([a-z]\w*(?!#)\b)/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\B#+([a-z]\\w*(?!#)\\b)', 'gi')
const str = `Hello #world
#lol #sorryNotSorry #heya #coolbeans
# # # #
this is an in#line hash
too ##many tags
invalid chars #\$? #;wha
#blue#red#yellow#green`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}