using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".+\/[^.\/]*?(?:\?.+)?$";
string input = @"http://www.example.com/
http://www.example.com/abc
http://www.example.com/abc/def/
http://www.example.com/abc/def.ext/
http://www.example.com/abc?param=abc.def
http://www.anything.com/abc/def.ext/?param=abc.ext
http://www.example.com/abc.ext
http://www.example.com/abc/def.ext
http://www.anything.com/abc/def.ext?param=abc
http://www.anything.com/abc/def.ext?param=abc.def";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}