import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".+\\/[^.\\/]*?(?:\\?.+)?$";
final String string = "http://www.example.com/\n"
+ "http://www.example.com/abc\n"
+ "http://www.example.com/abc/def/\n"
+ "http://www.example.com/abc/def.ext/\n"
+ "http://www.example.com/abc?param=abc.def\n"
+ "http://www.anything.com/abc/def.ext/?param=abc.ext\n\n"
+ "http://www.example.com/abc.ext\n"
+ "http://www.example.com/abc/def.ext\n"
+ "http://www.anything.com/abc/def.ext?param=abc\n"
+ "http://www.anything.com/abc/def.ext?param=abc.def";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}