const regex = /.+\/[^.\/]*?(?:\?.+)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.+\\\/[^.\\\/]*?(?:\\?.+)?$', 'gm')
const str = `http://www.example.com/
http://www.example.com/abc
http://www.example.com/abc/def/
http://www.example.com/abc/def.ext/
http://www.example.com/abc?param=abc.def
http://www.anything.com/abc/def.ext/?param=abc.ext
http://www.example.com/abc.ext
http://www.example.com/abc/def.ext
http://www.anything.com/abc/def.ext?param=abc
http://www.anything.com/abc/def.ext?param=abc.def`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}