use strict;
my $str = 'http://www.example.com/
http://www.example.com/abc
http://www.example.com/abc/def/
http://www.example.com/abc/def.ext/
http://www.example.com/abc?param=abc.def
http://www.anything.com/abc/def.ext/?param=abc.ext
http://www.example.com/abc.ext
http://www.example.com/abc/def.ext
http://www.anything.com/abc/def.ext?param=abc
http://www.anything.com/abc/def.ext?param=abc.def';
my $regex = qr/.+\/[^.\/]*?(?:\?.+)?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}