$re = '/.+\/[^.\/]*?(?:\?.+)?$/m';
$str = 'http://www.example.com/
http://www.example.com/abc
http://www.example.com/abc/def/
http://www.example.com/abc/def.ext/
http://www.example.com/abc?param=abc.def
http://www.anything.com/abc/def.ext/?param=abc.ext
http://www.example.com/abc.ext
http://www.example.com/abc/def.ext
http://www.anything.com/abc/def.ext?param=abc
http://www.anything.com/abc/def.ext?param=abc.def';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);