using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<iframe [^>]*?src=\""https?:\/\/(?:www\.)?youtu(?:be)?\.(?:com|be)\/(?:embed|watch)\/([^\?]*?)\?[^>]*?>\s*<\/iframe>";
string input = @"<iframe id=""ytplayer"" class=""EmbeddedVideo"" type=""text/html"" width=""640"" height=""390"" src=""https://youtube.com/embed/NOLILBSJbrs?html5=1&fs=1"" frameborder=""0"" allowfullscreen webkitallowfullscreen /></iframe>";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}