const regex = /<iframe [^>]*?src=\"https?:\/\/(?:www\.)?youtu(?:be)?\.(?:com|be)\/(?:embed|watch)\/([^\?]*?)\?[^>]*?>\s*<\/iframe>/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<iframe [^>]*?src=\\"https?:\\\/\\\/(?:www\\.)?youtu(?:be)?\\.(?:com|be)\\\/(?:embed|watch)\\\/([^\\?]*?)\\?[^>]*?>\\s*<\\\/iframe>', '')
const str = `<iframe id="ytplayer" class="EmbeddedVideo" type="text/html" width="640" height="390" src="https://youtube.com/embed/NOLILBSJbrs?html5=1&fs=1" frameborder="0" allowfullscreen webkitallowfullscreen /></iframe>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}