re = /<iframe [^>]*?src=\"https?:\/\/(?:www\.)?youtu(?:be)?\.(?:com|be)\/(?:embed|watch)\/([^\?]*?)\?[^>]*?>\s*<\/iframe>/
str = '<iframe id="ytplayer" class="EmbeddedVideo" type="text/html" width="640" height="390" src="https://youtube.com/embed/NOLILBSJbrs?html5=1&fs=1" frameborder="0" allowfullscreen webkitallowfullscreen /></iframe>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end