# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<iframe [^>]*?src=\"https?:\/\/(?:www\.)?youtu(?:be)?\.(?:com|be)\/(?:embed|watch)\/([^\?]*?)\?[^>]*?>\s*<\/iframe>"
test_str = "<iframe id=\"ytplayer\" class=\"EmbeddedVideo\" type=\"text/html\" width=\"640\" height=\"390\" src=\"https://youtube.com/embed/NOLILBSJbrs?html5=1&fs=1\" frameborder=\"0\" allowfullscreen webkitallowfullscreen /></iframe>"
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.