#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)<img.*src=[\"']([^\"']*)[\"'].*>"
Local $sString = "<img src="http://lorempixum.com/480/240/city/3.jpg" alt="Image 1" class="gallery-img" class="test-class">"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")