using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<img.*src=[\""']([^\""']*)[\""'].*>";
string input = @"<img src=""http://lorempixum.com/480/240/city/3.jpg"" alt=""Image 1"" class=""gallery-img"" class=""test-class"">";
RegexOptions options = RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}