package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)<img.*src=[\"']([^\"']*)[\"'].*>`)
var str = `<img src="http://lorempixum.com/480/240/city/3.jpg" alt="Image 1" class="gallery-img" class="test-class">`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}