re = /<img.*src=[\"']([^\"']*)[\"'].*>/i
str = '<img src="http://lorempixum.com/480/240/city/3.jpg" alt="Image 1" class="gallery-img" class="test-class">'
# Print the match result
str.match(re) do |match|
puts match.to_s
end