$re = '/<img.*src=[\"\']([^\"\']*)[\"\'].*>/i';
$str = '<img src="http://lorempixum.com/480/240/city/3.jpg" alt="Image 1" class="gallery-img" class="test-class">';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);