using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<div id=""latest_header""(?>.*?getNews\(')(?>(.*?)'\))(?>.*? )(?>(.*?)<br>)(?>.*?\.gif"">)(.*?)<\/label>";
string input = @"<div id=""latest_header"" onclick=""getNews('79');"">
<img src=""home_images/arrow.gif""> 2 DAY SEMINAR <br> <label id=""news_pagedesp""><img src=""home_images/li_desp.gif"">NATIONAL SEMINAR..</label><label id=""date_label"">13th August 2014</label></div>
<div id=""latest_header"" onclick=""getNews('78');"">
<img src=""home_images/arrow.gif""> 2 DAYS WORKSHOP <br> <label id=""news_pagedesp""><img src=""home_images/li_desp.gif"">INTERNATIONAL WOR..</label><label id=""date_label"">8th August 2014</label></div>";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}