import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<div id=\"latest_header\"(?>.*?getNews\\(')(?>(.*?)'\\))(?>.*? )(?>(.*?)<br>)(?>.*?\\.gif\">)(.*?)<\\/label>";
final String string = "<div id=\"latest_header\" onclick=\"getNews('79');\">\n"
+ " <img src=\"home_images/arrow.gif\"> 2 DAY SEMINAR <br> <label id=\"news_pagedesp\"><img src=\"home_images/li_desp.gif\">NATIONAL SEMINAR..</label><label id=\"date_label\">13th August 2014</label></div>\n"
+ "<div id=\"latest_header\" onclick=\"getNews('78');\">\n"
+ " <img src=\"home_images/arrow.gif\"> 2 DAYS WORKSHOP <br> <label id=\"news_pagedesp\"><img src=\"home_images/li_desp.gif\">INTERNATIONAL WOR..</label><label id=\"date_label\">8th August 2014</label></div>";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}