# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<div id=\"latest_header\"(?>.*?getNews\(')(?>(.*?)'\))(?>.*? )(?>(.*?)<br>)(?>.*?\.gif\">)(.*?)<\/label>"
test_str = ("<div id=\"latest_header\" onclick=\"getNews('79');\">\n"
" <img src=\"home_images/arrow.gif\"> 2 DAY SEMINAR <br> <label id=\"news_pagedesp\"><img src=\"home_images/li_desp.gif\">NATIONAL SEMINAR..</label><label id=\"date_label\">13th August 2014</label></div>\n"
"<div id=\"latest_header\" onclick=\"getNews('78');\">\n"
" <img src=\"home_images/arrow.gif\"> 2 DAYS WORKSHOP <br> <label id=\"news_pagedesp\"><img src=\"home_images/li_desp.gif\">INTERNATIONAL WOR..</label><label id=\"date_label\">8th August 2014</label></div>")
matches = re.finditer(regex, test_str, re.DOTALL)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.