use strict;
my $str = '<div id="latest_header" onclick="getNews(\'79\');">
<img src="home_images/arrow.gif"> 2 DAY SEMINAR <br> <label id="news_pagedesp"><img src="home_images/li_desp.gif">NATIONAL SEMINAR..</label><label id="date_label">13th August 2014</label></div>
<div id="latest_header" onclick="getNews(\'78\');">
<img src="home_images/arrow.gif"> 2 DAYS WORKSHOP <br> <label id="news_pagedesp"><img src="home_images/li_desp.gif">INTERNATIONAL WOR..</label><label id="date_label">8th August 2014</label></div>';
my $regex = qr/<div id="latest_header"(?>.*?getNews\(')(?>(.*?)'\))(?>.*? )(?>(.*?)<br>)(?>.*?\.gif">)(.*?)<\/label>/sp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}