using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(([1-9]|1\d|2[0-4])?\d|25[0-5])(\.(([1-9]|1\d|2[0-4])?\d|25[0-5])){3}$";
string input = @"0.1.3.4
255.250.255.1
1.0.0.127
25.23.12.350
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}