$re = '/^(([1-9]|1\d|2[0-4])?\d|25[0-5])(\.(([1-9]|1\d|2[0-4])?\d|25[0-5])){3}$/m';
$str = '0.1.3.4
255.250.255.1
1.0.0.127
25.23.12.350
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);