import re
regex = re.compile(r"^(([1-9]|1\d|2[0-4])?\d|25[0-5])(\.(([1-9]|1\d|2[0-4])?\d|25[0-5])){3}$", flags=re.MULTILINE)
test_str = ("0.1.3.4\n"
"255.250.255.1\n"
"1.0.0.127\n"
"25.23.12.350\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")