package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(([1-9]|1\d|2[0-4])?\d|25[0-5])(\.(([1-9]|1\d|2[0-4])?\d|25[0-5])){3}$`)
var str = `0.1.3.4
255.250.255.1
1.0.0.127
25.23.12.350
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}