// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(([1-9]|1\d|2[0-4])?\d|25[0-5])(\.(([1-9]|1\d|2[0-4])?\d|25[0-5])){3}$").unwrap();
let string = "0.1.3.4
255.250.255.1
1.0.0.127
25.23.12.350
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}