const regex = /[^(\x20-\x7F\n)]+/gu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^(\\x20-\\x7F\\n)]+', 'gu')
const str = `Punjab me 1Train🚊 k niche 100 👳Sardar aa gaye..
99 Mar gaye...
1 Bach gaya`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);