// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?u)[^(\x20-\x7F\n)]+").unwrap();
let string = "Punjab me 1Train🚊 k niche 100 👳Sardar aa gaye..
99 Mar gaye...
1 Bach gaya";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}